viernes, 14 de septiembre de 2012

Zentyal 3.0 : primeras impresiones [ Update 1]


[ Update 1 17-09-2011 ]

He probado Zentyal 3.0 en dos máquinas. Todavía no he visitado su base de datos de "bugs" pero me he encontrado el mismo error en dos máquinas distintas y de distinta arquitectura. El "bug"(realmente no sé si es un bug, pero todo apunta a que sí lo es) congela el proceso de instalación de software vía interfaz web. Mi solución ha sido matar el proceso apt y continuar la instalación desde la línea de comandos. Lo curioso del caso es que a posteriori he probado de nuevo Zentyal 3.0 dentro de un VirtualBox y he encontrado el mismo error. Supongo que toca investigar....

¿Actualizar desde la 2.2 a 3.0? Ummmmmmmmm, no me fío. Comentan en los foros de Zentyal:


I am sure the devs will do a great job on getting a decent upgrade path, but it will take some time (probably some weeks) before it is available.


[Post original]

Tenía ganas(muchas) de probar la nueva versión de Zentyal 3.0. No voy a contar/replicar/copiar/pegar las características de esta nueva versión, pues de gente de Zentyal lo ha hecho fenomenal en este link "Novedades Zentyal 3.0".

Actualmente administro máquinas corriendo Zentyal 2.X y los resultados no pueden ser más satisfactorios: estable, segura y muy sencilla de administrar. Conclusión: clientes contentos y reducción considerable del número de "browns"(Consultar el tratado del marrón) al simplificarse la administración del sistema.

Si ya estáis trabajando con Zentyal en producción el propio ssoo os avisará de la disponibilidad de la nueva versión. De momento está testeando al distribución en una máquina virtual. Veremos como se comporta en producción. El próximo fin de semana probaré esta nueva versión con 65 usuarios en el "IX Ciberencontro Concello de Mugardos  Kernel 2012" y os contaré cuál ha sido mi experiencia.

Ubuntu 10.04.1 LTS

Welcome to Ubuntu!
 * Documentation:  https://help.ubuntu.com/
New release 'precise' available.
Run 'do-release-upgrade' to upgrade to it.

                    *** Zentyal WARNING ***

Lo primero que me ha llamado la atención en el la versión 3.2.X del Kernel de Linux, por otro lado es obvio, puesto que está basada en Ubuntu 12.04 LTS. La instalación es muy similar(visualmente quiero decir), por no decir idéntica a versiones anteriores.


Finalizada la instalación sorprende(o no) la cuidad interfaz de administración. Si ya has utilizado Zentyal con anterioridad comprobarás como se han mejorado aspectos relacionados con la usabilidad de la interfaz. Además han añadido la opción de configuración de idioma desde la propia interfaz. Para "español" no hay problema. Para "galego" es necesario realizar la operación desde la línea de comandos.

Entrando ya en temas más concretos, personalmente me interensan los módulos HTTPProxy y VPN

Para el módulo HTTPProxy siguen apostando por Squid. Estos son los "pequeños" cambios que he apreciado a primera vista:
  • Pasan de la versión 2.7.STABLE7  a la 3.1.19-1. No tengo experiencia con Squid3(está mis objetivos a corto plazo, así que poco puedo aportar. Y eso? Pues en Debian Lenny siguen con 2.7 y por el momento....
  • Han mejorado la gestión de las "Delay pools".
  • Desde mi punto de vista han mejorado la gestión de las reglas de acceso. En esta nueva versión, aplicarlas es más intuitivo que la versión anterior.
Qué podrían mejorar?
  • Podrían incluír una opción para poder gestionar las políticas de control de caché. [ Más info ]
  • Podrían incluír una opción para poder gestionar "cache_peer" [ Más info ]

En resumen: Zentyal 3.0 es una solución estable y robusta para la implantación en PYME. Esta nueva versión, a pesar de no ser "revolucionaría", continúa con la progresión ascendente en cuanto a calidad, usabilidad y estabilidad de sus predecesores. Enhorabuena!


4 comentarios:

J. A. Calvo dijo...

Hola, el "bug" que comentas realmente sólo era un problema visual de la barra de progreso, apt estaba en ejecución correctamente y si hubieses esperado se habría instalado igualmente.

Esto debería estar solucionado ya en las nuevas versiones de paquetes que se publicaron ya hace unos días.

El problema ocurría sólo si instalabas en español o algun otro lenguaje con caracteres "especiales". Y tampoco siempre, supongo que dependía de que combinación de paquetes seleccionases, por tanto era dificil de detectar. El caso es que como digo debería estar ya arreglado.

Un saludo y gracias por tus comentarios!

Fon dijo...

Hola Alberto, ¿Puede ser que seas Gufi de Mugardos?

@apermuy dijo...

El mismo :)

Fon dijo...

Joder Gufi, yo soy Fon de Pedrós, no se si te acuerdas del instituto, intenté buscarte por facebook pero me fue imposible. Le mandé una solicitud de amistad a tu hermano pero creo que no se da cuenta quien soy. Me alegro de localizarte y de saber algo de tu vida (ya veo que te va bien) espero poder charlar un día contigo. Bueno mi facebook es Alfonso Pardo y mi correo alfonso.pardo@hotmail.com Un abrazo amigo.